Nutzen Sie Ihren Marketplace-Account für den Login in das Support-System.

Wissensdatenbank
Hotfix 4.1.00: Sicherheits-Patch
Gepostet von an 12 March 2015 10:28 AM

CORE-1164 Dieser Patch behebt ein schwerwiegendes Sicherheitsproblem, welches ausschließlich in Version 4.1.00 auftritt.

Installation:
- Erstellen Sie ein Backup von den Shop-Dateien und der Datenbank

- Laden Sie die Datei welche zu Ihrer php-Version passt herunter:

php-Version 5.2.x 5.3.x 5.4.x
Dateiname class.links.php_php5.2.zip class.links.php_fuer_php5.3.zip class.links.php_fuer_php5.4.zip

- Entpacken Sie die Datei und spielen Sie den Patch in den Ordner /xtFramework/classes/ und überschreiben Sie die gleichnamige Datei.
- Prüfen Sie nach der Installation Ihren Shop auf Funktionsfähigkeit.

 

Troubleshooting:

Problem: "weiße Seite" nach einspielen des Patches:

Dieses kann zwei Ursachen haben: Zum einen kann es sein, dass Sie den Patch für die falsche php-Version benutzt haben. ( Die php-Version Ihres Servers sehen Sie unter System => phpinfo im Backend des Shop) Zum andren kann es sein, dass Ihr Ioncube-Loader nicht aktuell ist. In letzterem Fall müssen Sie die aktuellen Loader für Ihr System installeren. (Die aktuellen laoder finden Sie hier: https://www.ioncube.com/loaders.php )

 

Update 14.03.2015:

class.links.php_php5.2.zip wurde ausgetauscht, nun sollten auch etwas ältere Ioncube-Loader unterstützt werden. (Sehr alte Loader müssen weiterhin aktualisiert werden.)



Anhänge 
 
 class.links.php_fuer_php5.4.zip (16.08 KB)
 class.links.php_fuer_php5.3.zip (16.06 KB)
 class.links.php_php5.2.zip (19.61 KB)